1
Philips Support

'SP' or 'Service Pack' error when loading the CD supplied with my Philips player

Published on 2017-08-24

You need to update your operating system. Your operating system does not meet the minimum system requirements. The minimum system requirement for this product is Windows XP (Home or Professional) SP2 (or above). For Windows XP users (Home or Professional), SP2 (or above) is required. The current link. The link may change in the future. Using a search engine with the following keywords should assist you: Windows XP Service Pack Download

Contact Philips

We are happy to help you

Looking for something else?

Discover all Philips Support options

Our site can best be viewed with the latest version of Microsoft Edge, Google Chrome or Firefox.